Access Virus & Virus TI community since 2002 Virus TI Infekted

Go Back   The Unofficial Access Virus & Virus TI Forum - since 2002 > Discussion concerning Access products > Trouble with your Access Virus?

Trouble with your Access Virus? Here you can get help when you have trouble or just don't know what to do.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11.09.2019, 12:24 PM
ColdFusion588 ColdFusion588 is offline
New here
New here
 
Join Date: 09.09.2019
Posts: 8
Default Should I avoid the 4.9 update for my Indigo?

My Indigo is currently running 4.07. I have not updated it yet as I have read about problems with some of the keyboard controllers and the latest 4.9 firmware. Is this a common problem? Can I cause any permanent problems with the keyboard attempting the update to 4.9? I'd certainly like the features but I don't want to lock up the keyboard or something like that.

Is anybody running 4.9 without problems in their Indigo?

Thanks,

Scott
Reply With Quote
  #2  
Old 11.09.2019, 12:59 PM
Timo's Avatar
Timo Timo is online now
Administrator
This forum member lives here
 
Join Date: 13.07.2003
Location: Kaoss central, England
Posts: 2,542
Default

Welcome.

Been using v4.9 (specifically 09.01.04 049) for well over a decade with no problems.

Seems some others experienced the problem you highlighted, though: http://www.infekted.org/virus/showthread.php?t=27319

From the above thread it seems if in the event it doesn't work it's possible to revert to the former OS that worked (for you), so I guess it would be important to have a file copy of the OS version you have (that works) before you start installing a newer one.
__________________
PS > And another thing! Will the Ti|3 have user customisable/importable wavetables? A ribbon-controller or XY-Pad might be nice, too, please! Thanks!
Reply With Quote
  #3  
Old 11.09.2019, 02:45 PM
ColdFusion588 ColdFusion588 is offline
New here
New here
 
Join Date: 09.09.2019
Posts: 8
Default

Thanks for the reply Timo. I'll try updating it and see what happens. Fortunately Access provides a fair number if old OS versions.
Reply With Quote
  #4  
Old 14.09.2019, 03:45 AM
ColdFusion588 ColdFusion588 is offline
New here
New here
 
Join Date: 09.09.2019
Posts: 8
Default

Sure enough, I was able to successfully transmit and program 4.9 into my Indigo and I followed instructions and turned it off for about 30 second following the successful completion of programming. I even held the LFO buttons to reset the machine.

It appeared to work but the keyboard goes nuts. It misses notes or they stick. Quite useless. I think this is a problem for early versions of the Indigo and KB which had keyboards controllers that weren't quite fully baked. This becomes especially apparent on later versions of software that started using the keyboard data at an apparently higher rate.

I am at the moment trying to load 4.52.
Reply With Quote
  #5  
Old 14.09.2019, 03:57 AM
ColdFusion588 ColdFusion588 is offline
New here
New here
 
Join Date: 09.09.2019
Posts: 8
Default

Grrr...

4.5.2 does the same thing. It's fairly clear the Virus synth and the keyboard are not talking at the same rate. Likely a serial interface not being clocked at the proper rate. Apparently Access knew about this problem. I wonder if anyone there still knows. Apparently the fix is supposed to be changing a crystal oscillator on the keyboard controller board. I can certainly handle that if Access will ship me the crystal or at least tell me what crystal I need.

I'm trying 4.5.1 right now but I think I'm probably going to have to go back to 4.0.7.
Reply With Quote
  #6  
Old 14.09.2019, 04:25 AM
ColdFusion588 ColdFusion588 is offline
New here
New here
 
Join Date: 09.09.2019
Posts: 8
Default Well, at least 4.51 works

So I just kept going back till the keyboard stopped freaking out and now looking at the OS change list it seems fairly obvious why this is the case. 4.52 is where they started handing keyboard velocity differently. I gather this is why it's broken for older Indigos that still have the early keyboard controller board.

OS 4.55
- Velocity response of the Virus bc and Indigo have been completely reworked

OS 4.52
- Velocity response of the Virus kb has been improved.
- "no velocity beyond 96" bug has been fixed

At least I get the 1024 preset slots. I'd love to have the Save To Flash feature, better velocity control, panning for mutis and the new arpeggiator patterns but that's not going to happen without a hardware change. I will post back here about how Access supports this old issue.
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 12:10 PM.
Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Skin Designed by: Talk vBulletin
Copyright �2002-2015, Infekted.org